老头子的博客  2018年07月23日 星期一

手机版

在MyEclipse下启动配置好的Tomcat报错:Can't load AMD 64-bit .dll on a IA 32-bit platform

问题现象

如下图:

10-1.png

分析原因

这个问题很蛋疼,提示是运行平台不一致导致。可是我的jdk、IDE、Tomcat和OS都是64位的,怎么可能会出现这个错误呢?在网上查了一下可能是MyEclipse用了其内置了jdk导致,所以修改MyEclipse内置jdk,如下图所示:

10-2.png

经过上面的操作还是涛声依旧啊,所以想是不是Tomcat内置的jdk也默认用了MyEclipse的呢?所以也将配置在MyEclipse的Tomcat的jdk也配置了一把,如下图所示:

10-3.png


我这里选择自己安装的jdk环境1.6


检查问题是否OK

运行效果如下图:

10-4.png


大功告成了!!

 


标签:
上一篇: StatSVN的使用
下一篇: ngrok.cc的使用(新版)

发表评论:

*